Only 1 Hit at a time for QBC batches

Discussion in 'Help & Guides' started by Michelle Smith, May 12, 2022 at 1:37 PM.

  1. Michelle Smith

    Michelle Smith Well-Known Turker

    Messages:
    1,630
    Gender:
    Female
    Ratings:
    +3,074
    When I get a batch from one of my watchers I'll only get one accepted at a time even if I have the queue cap set to a higher number. Is there something else I need to be changing to get in more at a time? What should 'Max Per Project' be set to?
     
  2. laby

    laby Survey Slinger Former MTG MotM TurkerView Masters

    Messages:
    13,378
    Gender:
    Female
    Ratings:
    +30,318
    Unless there is a short timer and I know I can't get the queue done before they expire I leave the queue cap on 0.
    Some batches end up being throttled if there are a lot of people doing it and I can't get more than a couple in my queue at a time.
     
  3. Michelle Smith

    Michelle Smith Well-Known Turker

    Messages:
    1,630
    Gender:
    Female
    Ratings:
    +3,074
    I'll try that then. Thanks so much! :emoji_hugging:
     
  4. j0sh83

    j0sh83 Survey Slinger

    Messages:
    4,308
    Gender:
    Male
    Ratings:
    +4,992
    If it is a batch requester, you do typically do not want to set a Max Project. This field should be 0 or blank.

    When you set a Max Project parameter, you are essentially telling QBC, "I only ever want to catch x amount for any GID from this requester." In turn QBC will create a block to prevent it from accepting anymore HITs with the same GID after it has reached that amount. This is useful for survey requesters, not for batch requesters.

    If you have been using Max Project for any of your batch RIDs, you should edit the watchers to remove Max Project and then go through your block list to double check that none are accidently blocked.

    upload_2022-5-14_14-50-59.png