[Please Help!] Mturk Suite & TurkerView

Discussion in 'Help & Guides' started by Espers, Feb 20, 2023.

  1. Espers

    Espers New Turker

    Messages:
    20
    Gender:
    Female
    Ratings:
    +1
    Hello

    I have Mturk Suite & TurkerView installed and everything was working great until about 5 days ago. I went to sync my information using the tracker and now that feature no longer works and my virus protector (Nod32) is blocking a file called trivial.o_spring.44. When I click on sync I get the message that google chrome tried to access that file and its blocked.

    I'm not sure what happened and I don't know why that one file is getting blocked all of sudden which makes me unable to sync.

    Any help with trying to figure out what could be causing this issue would be much appreciated.
     
  2. j0sh83

    j0sh83 Survey Slinger

    Messages:
    5,365
    Gender:
    Male
    Ratings:
    +7,932
    If the issue is just with this one file, are you able to set your antivirus to ignore it?

    Can you run a search on your PC and see where the file is stored (e.g. C:\blahblah\blah1\blah2....blahx)? I ran a search for it, and for just trivial and nothing came up. IDK if it will help, but would be curious to see where it is stored.
     
  3. Espers

    Espers New Turker

    Messages:
    20
    Gender:
    Female
    Ratings:
    +1
    I didn't find it either when I searched the C drive but thankfully Nod32 let me know where the file was located: C:\Users\AppData\Local\Google\Chrome\User Data\Default\IndexedDB\chrome-extension_iglbakfobmoijpbigmlfklckogbefnlf_0.indexeddb.leveld\494091.ldb

    When I went to the actually folder the 494091 file was removed by Nod32 and going by the other files within the folder the type says its a Microsoft Office Access Record-Locking Information one.

    I'm not sure how to unblock that one file within Nod32 so i would have to look into it.
     
    Last edited: Feb 22, 2023
  4. j0sh83

    j0sh83 Survey Slinger

    Messages:
    5,365
    Gender:
    Male
    Ratings:
    +7,932
    Interesting. I wish I had the knowledge to give you a definitive answer, but this is all just a shot in the dark.

    That folder is where MTS stores HIT Tracker data. You can confirm this for yourself if you open HIT Tracker in a new tab and then press F12. Look for the Application tab and you can see that your DB is stored in the same file name location.

    upload_2023-2-23_1-48-23.png

    Not sure why your antivirus is flagging this one ldb file. Perhaps its corrupted?

    Take this advice with caution. If you have not already tried, perhaps you should backup your HIT Tracker data and try to reinstall MTS. When you uninstall MTS, the database does not get deleted (in my experience), but the exported backup is your fall back just in case it does. The reason you may want to try this first is to see if by reinstalling cause chrome to write a new ldb file with a different sequential name that your antivirus does not flag.

    Again, not an expert in any of this, but you can see I have a bunch of different files that were created by HIT Tracker.

    upload_2023-2-23_1-47-4.png

    I would try the following.
    • Restart PC
    • Turn off antivirus.
    • Try a sync.
    • Backup
      • Whether sync worked should not matter since last sync was only 5-6 days ago.
    • Uninstall.
    • Reinstall.
    • Sync.
    • Import backup.
    • Sync.
    • Turn on antivirus.
    • Restart PC
    • Try a sync.
    If that does not work, maybe the work around is turning off your antivirus every time you want to sync. A more extreme measure would probably be to delete the database all together.

    Perhaps someone who is a lot smatter will weigh in with a more definitive answer or better solution.
     
    • Like Like x 1
    Last edited: Feb 23, 2023
  5. Espers

    Espers New Turker

    Messages:
    20
    Gender:
    Female
    Ratings:
    +1
    Temporally turning off Nod32 and restarting the browser allowed me to sync.

    Now for some reason its back working fine even with it on. I think you were right about the file being corrupted in some way since I can't explain why it started to work properly again and now I only have 9 of those .ldb files when there was way more last time I checked.

    I think I should leave it alone since its back working since I don't want to mess something up trying to figure out what happened in the first place.

    Thanks for all the help as well!
     
    • Like Like x 1
  6. j0sh83

    j0sh83 Survey Slinger

    Messages:
    5,365
    Gender:
    Male
    Ratings:
    +7,932
    Glad it worked itself out!